Issue
After integrating Defender for Endpoint with Red Canary, hostname records are displayed on the Endpoints page as <Unknown> (Sensor ID <value>).
Environment
Red Canary Portal
Microsoft Defender for Endpoint integration
Resolution
- Log into your Azure portal for the Tenant ID named in the associated Defender for Endpoint integration and navigate to Enterprise Apps
- Verify the Red Canary + ATP enterprise app is listed in this tenant
- Click into the app and navigate to Security > Permissions
- Ensure the following permission is granted to the app
- Machine.ReadWrite.All
- If the app, or any of its permissions are missing, have a user with active global administrator permissions click this consent link to re-provision the Red Canary + ATP app in your Azure tenant
Cause
The Red Canary + ATP enterprise app is either not found or missing permissions in the affected Tenant ID. The app and its permissions are required for Red Canary to make the necessary Defender for Endpoint API call to retrieve device details, including hostnames. After provisioning the app, hostnames will gradually be applied for endpoints that have recently checked into the Defender XDR console.
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