Issue
Customer stated that a developer was "dead in the water" Relating to NPM being blocked in Carbon Black despite the endpoint being allowed to run NPM scripts.
Environment
Carbon Black Cloud Enterprise EDR
Resolution
To resolve NX version-related blocking issues:
1. Confirm the blocked activity is expected to be allowed in the current policy.
2. Check which NX version the affected system is using.
3. Update the NX software to a newer version (later than version 19).
4. Verify that after the update, the blocking issue no longer occurs.
Cause
NX version 19 was causing blocked activity that should have been permitted per existing policy settings.
Keywords: NX version block, NPM Block policy issue, policy allows but blocked, voicemail developer blocked, update NX resolves block, Carbon Black Cloud Enterprise EDR NX problem, version 19 software issue, cannot work due to NPM block, developer dead in the water, voicemail call for unblock, emergency number voicemail block
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