Issue
Crowdstrike Host Groups are not Syncing and showing up as Sensor Groups in Red Canary portal.
Environment
Red Canary + Crowdstrike
Resolution
Either we or the Customer will need to configure "Read" permissions for Host Groups in their Red Canary Oauth2 API inside of Crowdstrike. This setting can be found by logging into the Customers Crowdstrike Tenant and navigating to: Support and Resources > API Clients & Keys > Oauth2 API Clients tab. Then perform the following steps:
- Find the "Red Canary" API client.
- Click the three dot menu next to the "Red Canary" API client entry and select "Edit API client."
- Check the boxes for "Read" permissions for the "Host Groups" setting.
Cause
This is caused by lack of Read API permissions for the Host Groups API Scope.
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