Issue
Troubleshooting the VMware CBC sensor can be difficult without reviewing the logs. In case the RepCLI commands are not working you will need to manually review the logs.
Environment
VMware Carbon Black Cloud sensor for Windows Endpoints
Resolution
Sensor logs are stored in C:\ProgramData\CarbonBlack\Logs\confer
Depending on how the sensor was installed, there are other locations where sensor logs may be found (the installer log may be named cb-installer-x-x-x.log or will contain "installer" in the filename):
%LocalAppData\Temp
%SystemRoot%\Temp
For installation logs:
- Sensor logs
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Pre 3.6 - C:\Program Files\Confer
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Post 3.6 - C:\ProgramData\CarbonBlack\Logs
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- Microsoft Windows Installer Log (msi.log)
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Pre 3.6 - C:\Program Files\Confer
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Post 3.6 - C:\ProgramData\CarbonBlack\Logs
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- Sensor Install Log (confer-temp.log).
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C:\Users\<user>\AppData\Local\Temp\
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C:\Windows\TEMP\
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C:\Users\All Users\AppData\Local\Temp
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Cause
If RepCLI is not working, the commands to collect the diagnostics logs may fail.