Issue
When the customer tries to run the installed the installer ends in an error.
Action ended 11:10:57: CustomActionId.InstallPreCheck. Return value 3.
Action ended 11:10:57: INSTALL. Return value 3.
Environment
Carbon Black Enterprise EDR sensor 3.6.0.1941
Windows 10 endpoint
Resolution
If the installer is being executed from a shared folder, the solution is to right-click on the installer executable and select Run as Administrator.
Cause
Logs show that the issue is due to the customer/user not having full admin rights for the installation. The installer is not able to initialize ending in a return value 3.
Action ended 11:10:57: CustomActionId.CheckElamSupportedOS. Return value 1.
Action start 11:10:57: CustomActionId.InstallPreCheck.
CA:InstallPreCheck: Entering CA:InstallPreCheck in C:\Windows\Installer\MSI1AE9.tmp, version 3.6.0.1941
CA:InstallPreCheck: 3.6.0.1941:CAInstallPreCheck: Initialized.
CA:InstallPreCheck: UILEVEL = 2
CA:InstallPreCheck: OFFLINE_INSTALL =
CA:InstallPreCheck: OFFLINE_INSTALL = FALSE
CA:InstallPreCheck: COMPANY_CODE = <Company Code>
CA:InstallPreCheck: USER_EMAIL =
CA:InstallPreCheck: PROXY_USER =
CA:InstallPreCheck: CheckUpdate: ProductVersion = 3.6.0.1941, ProductCode = {48BLAH7F-9E77-49D4-891E-8276C87BD284}
CA:InstallPreCheck: CheckUpdate: WIX_UPGRADE_DETECTED =
CA:InstallPreCheck: CheckUpdate: UPGRADINGPRODUCTCODE =
CA:InstallPreCheck: CheckUpdate: This is a fresh install.
CA:InstallPreCheck: Error 0x80004005: CAInstallPreCheck: Failed because the install user does not have admin privilege.
CustomAction CustomActionId.InstallPreCheck returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
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